Back to overview
Downtime

Snapaper Paper Service is Temporarily Unavailable

Dec 20, 2023 at 04:33pm UTC
Affected services
Snapaper Service
Snapaper Paper Service

Resolved
Jan 07, 2024 at 11:42pm UTC

We have managed to switched to another paper source, services are partially back up online.

Created
Dec 20, 2023 at 04:33pm UTC

GCE Guide website is down. There is nothing we can do at this time, please be patient and wait for further updates. Thank you.